MPLS配置实验

   日期:2020-11-17     浏览:24    评论:0    
核心提示:文章目录实验要求实验拓扑实验配置实验结果实验要求R1与R5 MPLS VPNR6与R7 MPLS VPNR7可以访问R2/3/4的环回实验拓扑实验配置1.IP接口地址及路由器环回地址配置[Huawei]sysname r2[r2]int LoopBack 0[r2-LoopBack0]ip add 2.2.2.2 24[r2-LoopBack0]int g0/0/1[r2-GigabitEthernet0/0/1]ip add 23.1.1.1 24[Huawei]sysn

文章目录

      • 实验要求
      • 实验拓扑
      • 实验配置
      • 实验结果

实验要求

  1. R1与R5 MPLS VPN
  2. R6与R7 MPLS VPN
  3. R7可以访问R2/3/4的环回

实验拓扑

实验配置

1.IP接口地址及路由器环回地址配置

[Huawei]sysname r2
[r2]int LoopBack 0
[r2-LoopBack0]ip add 2.2.2.2 24
[r2-LoopBack0]int g0/0/1
[r2-GigabitEthernet0/0/1]ip add 23.1.1.1 24

[Huawei]sysname r3
[r3]int LoopBack 0
[r3-LoopBack0]ip add 3.3.3.3 24
[r3-LoopBack0]int g0/0/0
[r3-GigabitEthernet0/0/0]ip add 23.1.1.2 24
[r3-GigabitEthernet0/0/0]int g0/0/1
[r3-GigabitEthernet0/0/1]ip add 34.1.1.1 24

[Huawei]sysname r4
[r4]int LoopBack 0
[r4-LoopBack0]ip add 4.4.4.4 24
[r4-LoopBack0]int g0/0/0
[r4-GigabitEthernet0/0/0]ip add 34.1.1.2 24
[r4-GigabitEthernet0/0/0]int g0/0/2
[r4-GigabitEthernet0/0/2]ip add 47.1.1.1 24

[Huawei]sysname r7
[r7]int g0/0/2
[r7-GigabitEthernet0/0/2]ip add 47.1.1.2 24

2.在R2、R3、R4内启动OSPF,构建公网,构建MPLS
配置OSPF

[r2]ospf 1 router-id 2.2.2.2
[r2-ospf-1]area 0
[r2-ospf-1-area-0.0.0.0]network 23.1.1.1 0.0.0.0
[r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0

[r3]ospf 1 router-id 3.3.3.3
[r3-ospf-1]area 0
[r3-ospf-1-area-0.0.0.0]network 23.1.1.2 0.0.0.0
[r3-ospf-1-area-0.0.0.0]network 34.1.1.1 0.0.0.0
[r3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0

[r4]ospf 1 router-id 4.4.4.4
[r4-ospf-1]area 0
[r4-ospf-1-area-0.0.0.0]network 34.1.1.2 0.0.0.0
[r4-ospf-1-area-0.0.0.0]network 47.1.1.1 0.0.0.0
[r4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0
[r4]ospf 1
[r4-ospf-1]silent-interface g0/0/2   
配置静默接口,静止收发Hello报文,但不妨碍R4通过OSPF学习去往这两个接口所在网段的路由
[r7]ip route-static 0.0.0.0 0 47.1.1.1
在R7上配置静态路由

配置MPLS

[r2]mpls lsr-id 2.2.2.2
[r2]mpls
Info: Mpls starting, please wait... OK!
[r2-mpls]mpls ldp
[r2-mpls-ldp]int g0/0/1
[r2-GigabitEthernet0/0/1]mpls
[r2-GigabitEthernet0/0/1]mpls ldp

[r3]mpls lsr-id 3.3.3.3
[r3]mpls
Info: Mpls starting, please wait... OK!
[r3-mpls]mpls ldp
[r3-mpls-ldp]int g0/0/0
[r3-GigabitEthernet0/0/0]mpls
[r3-GigabitEthernet0/0/0]mpls ldp
[r3-GigabitEthernet0/0/0]int g0/0/1
[r3-GigabitEthernet0/0/1]mpls
[r3-GigabitEthernet0/0/1]mpls ldp

[r4]mpls lsr-id 4.4.4.4
[r4]mpls
Info: Mpls starting, please wait... OK!
[r4-mpls]mpls ldp
[r4-mpls-ldp]int g0/0/0
[r4-GigabitEthernet0/0/0]mpls
[r4-GigabitEthernet0/0/0]mpls ldp

配置BGP

[r2]bgp 1
[r2-bgp]router-id 2.2.2.2
[r2-bgp]peer 4.4.4.4 as-number 1
[r2-bgp]peer 4.4.4.4 connect-interface loopback 0
[r2-bgp]ipv4-family vpnv4
[r2-bgp-af-vpnv4]peer 4.4.4.4 enable
[r2-bgp-af-vpnv4]peer 4.4.4.4 adver	
[r2-bgp-af-vpnv4]peer 4.4.4.4 advertise-community 

[r4-bgp]router-id 4.4.4.4
[r4-bgp]peer 2.2.2.2 as-number 1
[r4-bgp]peer 2.2.2.2 con	
[r4-bgp]peer 2.2.2.2 connect-interface loopback 0
[r4-bgp]ipv4-family vpnv4
[r4-bgp-af-vpnv4]peer 2.2.2.2 enable

开始接入用户(静态)

[r2]ip vpn-instance b
[r2-vpn-instance-b]ipv4-family
[r2-vpn-instance-b-af-ipv4]route-distinguisher 1:1
[r2-vpn-instance-b-af-ipv4]vpn-target 1:1
[r2-vpn-instance-b-af-ipv4]q
[r2-vpn-instance-b]int g0/0/0
[r2-GigabitEthernet0/0/0]ip binding vpn-instance b
[r2-GigabitEthernet0/0/0]ip add 192.168.2.2 24

[Huawei]sysname r1
[r1]int lo 0
[r1-LoopBack0]ip add 192.168.1.1 24
[r1-LoopBack0]int g0/0/1
[r1-GigabitEthernet0/0/1]ip add 192.168.2.1 24

[r4]ip vpn-instance b
[r4-vpn-instance-b]ipv4-family
[r4-vpn-instance-b-af-ipv4]route-distinguisher 1:1
[r4-vpn-instance-b-af-ipv4]vpn-target 1:1
[r4-vpn-instance-b-af-ipv4]q
[r4-vpn-instance-b]int g0/0/1
[r4-GigabitEthernet0/0/1]ip binding vpn-instance b
[r4-GigabitEthernet0/0/1]ip add 192.168.3.1 24

[Huawei]sysname r5
[r5]int lo 0
[r5-LoopBack0]ip add 192.168.4.1 24
[r5-LoopBack0]int g0/0/0
[r5-GigabitEthernet0/0/0]ip add 192.168.3.2 24

[r1]ip route-static 192.168.3.0 24 192.168.2.2
[r1]ip route-static 192.168.4.0 24 192.168.2.2

[r2]ip route-static vpn-instance b 192.168.1.0 24 192.168.2.1
[r2]bgp 1
[r2-bgp]ipv4-family vpn-instance b
[r2-bgp-b]import-route direct
[r2-bgp-b]import-route static

[r4]ip route-static vpn-instance b 192.168.4.0 24 192.168.3.2
[r4]bgp 1
[r4-bgp]ipv4-family vpn-instance b
[r4-bgp-b]import-route static
[r4-bgp-b]import-route direct

[r5]ip route-static 192.168.1.0 24 192.168.3.1
[r5]ip route-static 192.168.2.0 24 192.168.3.1

(动态)

[r2]ip vpn-instance a
[r2-vpn-instance-a]ipv4-family
[r2-vpn-instance-a-af-ipv4]route-distinguisher 2:2
[r2-vpn-instance-a-af-ipv4]vpn-target 2:2
[r2-vpn-instance-a-af-ipv4]q
[r2-vpn-instance-a]int g0/0/2
[r2-GigabitEthernet0/0/2]ip binding vpn-instance a
[r2-GigabitEthernet0/0/2]ip add 192.168.2.2 24

[r4]ip vpn-instance a
[r4-vpn-instance-a]ipv4-family
[r4-vpn-instance-a-af-ipv4]route-distinguisher 2:2
[r4-vpn-instance-a-af-ipv4]vpn-target 2:2
[r4-vpn-instance-a-af-ipv4]q
[r4-vpn-instance-a]int g0/0/2
[r4-GigabitEthernet0/0/2]ip binding vpn-instance a
[r4-GigabitEthernet0/0/2]ip add 192.168.3.1 24

[Huawei]sysname r6
[r6]int lo 0
[r6-LoopBack0]ip add 192.168.1.1 24
[r6-LoopBack0]int g0/0/2
[r6-GigabitEthernet0/0/2]ip add 192.168.2.1 24

[r7]int lo 0
[r7-LoopBack0]ip add 192.168.4.2 24
[r7-LoopBack0]int g0/0/2
[r7-GigabitEthernet0/0/2]ip add 192.168.3.2 24

[r6]rip 1
[r6-rip-1]version 2
[r6-rip-1]un summary
[r6-rip-1]network 192.168.1.0
[r6-rip-1]network 192.168.2.0

[r2]rip 1 vpn-instance a
[r2-rip-1]version 2
[r2-rip-1]un summary
[r2-rip-1]network 192.168.2.0

[r4]ospf 2 vpn-instance a
[r4-ospf-2]area 0
[r4-ospf-2-area-0.0.0.0]network 192.168.3.1 0.0.0.0

[r7]ospf 1 router-id 7.7.7.7
[r7-ospf-1]area 0
[r7-ospf-1-area-0.0.0.0]network 192.168.3.2 0.0.0.0
[r7-ospf-1-area-0.0.0.0]network 192.168.4.2 0.0.0.0

[r2]rip 1 vpn-instance a
[r2-rip-1]import-route bgp
[r2-rip-1]q
[r2]bgp 1
[r2-bgp]ipv4-family vpn-instance a
[r2-bgp-a]import-route rip 1

[r4]ospf 2 vpn-instance a
[r4-ospf-2]import-route bgp
[r4-ospf-2]q
[r4]bgp 1
[r4-bgp]ipv4-family vpn-instance a
[r4-bgp-a]import-route ospf 2

实验结果


 
打赏
 本文转载自:网络 
所有权利归属于原作者,如文章来源标示错误或侵犯了您的权利请联系微信13520258486
更多>最近资讯中心
更多>最新资讯中心
0相关评论

推荐图文
推荐资讯中心
点击排行
最新信息
新手指南
采购商服务
供应商服务
交易安全
关注我们
手机网站:
新浪微博:
微信关注:

13520258486

周一至周五 9:00-18:00
(其他时间联系在线客服)

24小时在线客服